Source
Journeys & orchestration — found from sitemap — Adobe Marketo Engage
Checked for Adobe Marketo Engage on 1 Oct 2026
- Page
- https://developer.adobe.com/journey-optimizer-apis/references/journeys-throttling
- Checked
- 1 Oct 2026, 09:56 UTC
- How we may use it
- Public page, crawling permitted
Technical details
- type
- page
- http status
- 200
- content hash
- sha256:1f792ab0108e5025a640411a1224590bcb0b74f729ae526028ed672040062c18
- permission
- robots_ok
- screenshot
- Screenshot on file (internal exhibit, not published)
Cited by
Facts read from this source
-
Throttling API purpose Report an error
“The Journeys throttling configuration APIs allow to manage capping and throttling configurations.”
-
Auth method Report an error
“They are accessible by an authorized technical account created through the Adobe Developer Console.”
-
Postman collections Report an error
“Visualize API calls with Postman: Capping API - Postman collection on GitHub Throttling API - Postman collection on GitHub”
-
Openapi spec Report an error
“Download OpenAPI specification:Download”
-
Base path Report an error
“Base path for this API {BASE_PATH} : /journey/orchestration Example of a complete path: https://platform.adobe.io/journey/orchestration/endpointConfigs”
-
Required headers Report an error
“All calls require the authentication headers Authorization, x-api-key, and x-gw-ims-org-id.”
-
Sandbox isolation Report an error
“All resources in Experience Platform and Journey Optimizer are isolated to specific virtual sandboxes. All requests to these APIs require the header x-sandbox-name”
-
Config states Report an error
“The current state of a capping or throttling configuration is either 'created', 'updated' or 'deployed'.”
-
Can deploy check Report an error
“In creation and update responses, a canDeploy JSON object indicates whether or not a configuration can be deployed.”
-
Throttling required attributes Report an error
“You must provide all the following attributes when creating or updating a throttling configuration: 'maxThroughput', 'urlPattern' and 'methods'.”
-
Throttling org level limit Report an error
“A throttling configuration must be defined on a production sandbox (given through x-sandbox-name header). It is applied at organization level. Only one throttling configuration is currently allowed per organisation.”
-
Capping config fields Report an error
“url : the URL of the endpoint, as defined in the actions or data sources. methods : the methods called on this endpoint, as defined in the actions or data sources.”
-
Capping service scope Report an error
“"action" if the capping will be applied on the endpoint when executing a Custom Action "dataSource" if the capping will be applied on the endpoint when fetching data from a Data Source”
-
Capping max http connections Report an error
“(optional) maxHttpConnections: max count of simultaneous connections to the endpoint (max value is 400). If not provided, there will be no limitation of the number of connections to the endpoint.”
-
Capping rating fields Report an error
“maxCallsCount: max count of calls to be performed in the given period (min value is 1) periodInMs: duration in milliseconds (value greater than 0)”
-
Http methods enum Report an error
“Items Enum: "GET" "POST" "PUT" "PATCH" "DELETE" "OPTION"”
-
Capping endpoints Report an error
“POST /endpointConfigs Try it”
-
Throttling endpoints Report an error
“POST /list/throttlingConfigs”
-
Deployed delete guard Report an error
“In case the configuration has been deployed, it must be undeployed before being deleted. Otherwise an error response with HTTP Status Code 500 is returned”
-
Can deploy validation statuses Report an error
“It returns the validation status of the configuration identified by its Unique ID, either: "ok" "error"”
-
Capping validation errors Report an error
“ERR_ENDPOINTCONFIG_100: capping config: missing or invalid url ERR_ENDPOINTCONFIG_101: capping config: malformed url”
-
Update overwrite semantics Report an error
“The operation is an overwrite of the existing configuration, therefore the request body must include all fields required to create a configuration.”
-
Deployment state change Report an error
“A successful deployment returns an empty response body and HTTP Status Code 204 (No-content). In such case, the configuration state is changed to 'deployed' and hasBeenDeployed is true.”
-
Docs link Report an error
“Learn more about the capping and throttling mechanisms in the following documentation: Journeys integration with external systems”
Scores citing this record
- The Data Protection Officer Journeys & orchestration
- The Data Protection Officer Channels & personalisation
- The Data Protection Officer Consent, tracking & profiling
- The Data Protection Officer European sovereignty
- The Data Protection Officer Pricing transparency
- The Demand Gen Lead Journeys & orchestration
- The Demand Gen Lead Channels & personalisation
- The Demand Gen Lead CRM integration & data model
- The Demand Gen Lead European sovereignty
- The Demand Gen Lead Pricing transparency
- The Lifecycle Marketer Journeys & orchestration
- The Lifecycle Marketer Channels & personalisation
- The Lifecycle Marketer Pricing transparency
- The Sales Ops Manager Journeys & orchestration
- The Sales Ops Manager Channels & personalisation
- The Sales Ops Manager European sovereignty
- The Sales Ops Manager Pricing transparency
- The Skeptic Journeys & orchestration
- The Skeptic Channels & personalisation
- The Skeptic European sovereignty
- The Skeptic Pricing transparency
- The Solution Architect Journeys & orchestration
- The Solution Architect Consent, tracking & profiling
- The Solution Architect CRM integration & data model
- The Solution Architect European sovereignty
- The Solution Architect Pricing transparency